re = /(?i:([;]|^)([a-z0-9.]+@(dom\.net|part1\.part2\.uk))(?=[;]|$))/
str = 'a.name@part1.part2.uk;a.name@dom.net'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end