// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)goDetail\(\'(\w+).*\'([\d-]+\(\d+\))").unwrap();
let string = "<tbody>
<tr class=\"td_odd\" onclick=\"goDetail('101','70-1-44-1(035)')\"
style=\"cursor:pointer;\">
<td align=\"center\" valign=\"middle\">1</td>
<td align=\"center\" class=\"td-line\" valign=\"middle\">效期內</td>
</tr>
<tr class=\"td_event\" onclick=\"goDetail('301','40-107-4-1(9918)')\"
style=\"cursor:pointer;\">
<td align=\"center\" valign=\"middle\">2</td>
<td align=\"center\" class=\"td-line\" valign=\"middle\">效期內</td>
</tr>
<tr class=\"td_odd\" onclick=\"goDetail('502','53-1-42-1(531)')\"
style=\"cursor:pointer;\">
<td align=\"center\" valign=\"middle\">1</td>
<td align=\"center\" class=\"td-line\" valign=\"middle\">效期內</td>
</tr>
</tbody>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}