using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[?&]tab_id=)[^&]+";
string input = @"https://some-domain/auth/authenticate?auth=1c4cf948-0867-488d-8596&client_id=account&tab_id=0p-SoVza1Sw";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}