re = /(?<=[?&]tab_id=)[^&]+/m
str = 'https://some-domain/auth/authenticate?auth=1c4cf948-0867-488d-8596&client_id=account&tab_id=0p-SoVza1Sw'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end