#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[Mm]od(?!e?r|if).*[\W_][hH]\b"
Local $sString = "new modified of module h 1" & @CRLF & _
"of mod H" & @CRLF & _
"new of mod_H" & @CRLF & _
"new moderate of mod_H" & @CRLF & _
"to modules (A & h)" & @CRLF & _
"" & @CRLF & _
"new modified and moderate H" & @CRLF & _
"new modification of A mod_A" & @CRLF & _
"to modules (D & E)" & @CRLF & _
"to mode (F, G & A)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")