import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[Mm]od(?!e?r|if).*[\\W_][hH]\\b";
final String string = "new modified of module h 1\n"
+ "of mod H\n"
+ "new of mod_H\n"
+ "new moderate of mod_H\n"
+ "to modules (A & h)\n\n"
+ "new modified and moderate H\n"
+ "new modification of A mod_A\n"
+ "to modules (D & E)\n"
+ "to mode (F, G & A)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}