$re = '/(\d+)\*(\d+)/';
$str = 'X=5+5*6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);