const regex = new RegExp('(?:(\\"uuid\\":\\"(?<uuidValue>\\w{8}-(?:(\\w{4}-){3})\\w{12}))\\")', '')
const str = `{"uuid":"ae7f5827-e29e-462f-b5f7-ace16cf5b18f","orderId":"ATLAS48315`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}