use strict;
my $str = 'Banana lmasfh asfjhas jhona uh3 a y u3u3 303303 ajksdfkas 3jk5hk
Banana lmasfh asfjhas jhona uh3 a y u3u3 202202 ajksdfkas 3jk5hk
Apple lmasfh asfjhas jhona uh3 a y u3u3 101101 ajksdfkas 3jk5hk';
my $regex = qr/(?<=^Banana).*(\d{6})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}