import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\\\)![^!\\\\.]*(?:(?:\\.(?!\\.\\.)|(?=(\\.{3}.*?\\.{3}))\\1|\\\\.)[^!\\\\.]*)*!";
final String string = "!Normal string!\n"
+ "!String with escaped \\! exclamation mark!\n"
+ "!String with a comment ... comment ...!\n"
+ "!String \\! with both ... comments can have unescaped exclamation marks!!!... !\n\n"
+ "test ...this is a comment... test\n\n"
+ "\\!String \\! with both ... comments can have unescaped exclamation marks!!!...... !\n\n"
+ "!S...test...\\!tring \\! with both ... comments can have unescaped exclamation marks ...test...\\!tring \\! with both ... comments can have unescaped exclamation marks ...test...\\!tring \\! with both ... comments can have unescaped exclamation marks ...test...\\!tring \\! with both ... comments can have unescaped exclamation marks ...test...\\!tring \\! with both ... comments can have unescaped exclamation marks \n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}