re = /(?<!\\)![^!\\.]*(?:(?:\.(?!\.\.)|(?=(\.{3}.*?\.{3}))\1|\\.)[^!\\.]*)*!/m
str = '!Normal string!
!String with escaped \\! exclamation mark!
!String with a comment ... comment ...!
!String \\! with both ... comments can have unescaped exclamation marks!!!... !
test ...this is a comment... test
\\!String \\! with both ... comments can have unescaped exclamation marks!!!...... !
!S...test...\\!tring \\! with both ... comments can have unescaped exclamation marks ...test...\\!tring \\! with both ... comments can have unescaped exclamation marks ...test...\\!tring \\! with both ... comments can have unescaped exclamation marks ...test...\\!tring \\! with both ... comments can have unescaped exclamation marks ...test...\\!tring \\! with both ... comments can have unescaped exclamation marks
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end