re = /<a.*\[monitory\].*href=["|']([http:|https:]?[\/\/]?.*?)["|']>/m
str = '<a [monitory] href=|http:/www.teste.com|>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end