$re = '/\s*Million \(USD\)\s*$/m';
$str = '2.7 Million (USD)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);