$re = '/\b(\d+)(?:\.0+|(\.\d+?))0*\b/m';
$str = 'bla 500.00
bla 1.20000
bla 1.10
bla 2.34
bla 2.340003
bal 1.032';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;