use strict;
my $str = '90/09/2018';
my $regex = qr/^(?<tgl>\d{2})\/(?<bln>[0-1][0-9]{1,2})\/(?<thn>\d{4})$/sp;
my $subst = 'Gafur';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";