// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)^(?<tgl>\d{2})\/(?<bln>[0-1][0-9]{1,2})\/(?<thn>\d{4})$").unwrap();
let string = "90/09/2018";
let substitution = "Gafur";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}