$re = '/(?<=CHF|\$).+/m';
$str = '$500.00
CHF28,8,8890.95';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);