$re = '/^(?:[^.\r\n]+\.){11}([^.\r\n]+)\.([^.\r\n]+)\.(?!ok\b|cancelled\b)([^.\r\n]+)\.(?:[^.\r\n]+)$/m';
$str = 'group.cluster.namespace.release.app.pod.timer.grpc.server.processing.duration.package.method.ok.count
group.cluster.namespace.release.app.pod.timer.grpc.server.processing.duration.package.method.cancelled.count
group.cluster.namespace.release.app.pod.timer.grpc.server.processing.duration.package.method.error.count';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);