re = /[a-zA-Z0-9._%+-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,4}/
str = 'br.uno.lesi.eur@gmail.com
brunolesieur@gmail.com
bruno.lesieur@gmail.com
.brunolesieur@gmail.com
brunolesieur.@gmail.com
bru..no.lesieu..r@gmail.com
bruno.lesieur+divers-truc-ici@gmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end