import re
regex = re.compile(r"\$\s?(\d+[\.\s,\dk]+)|(\d+[\.\s,\dk]+)\$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("I know most of you don't know me but i've been a member with a strong presence on m5board for about 5 years now.\n"
"Username there is the same as here: CarbonHan\n"
"History:\n"
"I've owned the car since it had 64k miles on it and purchased it from a fellow enthusiast from this board. I also purchased an aftermarket warranty for the car that was effective until the car had 114k miles (roughly 2 years ago). I replaced everything and anything that i could within that time frame. Unfortunately for my wallet, the only thing I needed the warranty for was one bad cps sensor and a bad coil pack. The car has been maintained by the same mechanic the previous owner used: Qais at Southbay Autohaus.\n"
" Here's his website:South Bay Hautohaus\n"
"Call him and ask about my car. He'll tell you a funny story about how he refused to change out my rod bearings because he said I would be wasting my money haha\n"
"Specs:\n"
"144k miles\n"
"2002 Carbon Black E39 M5\n"
"Exclusive(Luxury) interior package(extended black leather) with Bruyere Wood Trim\n"
"Alcantara anthracite headliner\n"
"Rear fold down seats with ski pass\n"
"M-Audio\n"
"Factory rear spoiler delete\n"
"It has all options minus the PDC and window/rear shades\n"
"You can look up some of the specs here:BMW Baureihenarchiv - BMW Vehicle Identification Number (VIN) | bmwarchiv.de\n"
"Last 7 digits of my vin: CF90317Here's the bad first:\n"
"1)Car was rear ended 4 years ago in bumper to bumper traffic. Girl behind me was reaching for her inhaler and let go of the brakes. Very minor damage to the trunk and rear bumper. Had them both replaced and painted here: C&C Collision, Auto Body Repair Shop - Home (Squeaky clean Carfax)\n"
"2) The power steering pulley slightly squeals during warm up\n"
"3) The plastic piece that goes underneath the right corner of the front bumper is cracked\n"
"4) I'm missing the latch that covers the oil drain plug\n"
"5) The 2 plastic pieces that go along the firewall inside of the engine bay are cracked\n"
"6) My fold up mirrors \"work\"\n"
"7) Door seals creak or at least i think they are. They just haven't been replaced before so i'm assuming.\n"
"8) Center console armrest leather is fading\n"
"9) Driver side seat bolster leather is fading\n"
"10) I'm pretty sure I have 1 door ding somewhere\n"
"11) Rear view mirror has a bubble - NOT LEAKING\n"
"Mods:\n"
"BC 8/6k Coilovers with updated koyo bearings\n"
"Dinan Front strut bar\n"
"Dinan rear sway bar\n"
"Beast power sway bar brackets with polyurethane inserts\n"
"Stoptech slotted rotors w/ pagid pads\n"
"19x10 ESM LM rep wheels +15 offset Square set up on Hk Ventus v12 275/30/35/19\n"
"Predator39 Clear cornered headlights w/ 6k bulbs\n"
"Orion v2 6k Angel eyes\n"
"Muffler delete\n"
"E60 SSk\n"
"Shorty clutch stop\n"
"DICE iPod integration kit\n"
"Huper Optik Ceramic tint 40%\n"
"Black Bimmian kidney grills\n"
"Custom Jailbreak Tune hybrid Alpha-N ~352.36/340.57 WHP/TQ\n"
"(SAP SES light delete, De-limited, STOCK redline, Sport mode memory)\n"
"Maintenance: ALL OEM\n"
"NO LEAKS WHATSOEVER/ DOESN'T DRINK A DROP OF OIL\n"
"When i went to go get my car dyno tuned Matt told me that my car was the first and only car not to leave any sort of residue on the ground\n"
"I've use Castrol TWS since day one until my MOST recent oil change 2k miles ago. I used LiquiMoly 10w60\n"
"NO DEAD PIXELS\n"
"Battery ~ @115k miles\n"
"Spark plugs ~ @90k miles\n"
"Coil packs ~ @90k miles\n"
"4 CPS ~ 6k miles ago\n"
"2 TPS ~ 6k miles ago\n"
"2 MAFs ~ 8k miles ago\n"
"Thermostat ~ 15k miles ago\n"
"Fan Clutch & fan ~ 15k miles ago\n"
"Oil separators ~ 15k miles ago\n"
"All the temp sensors ~ 15k miles ago\n"
"Radiator flush ~ 15k miles ago\n"
"Valve cover gaskets and accessories ~ 10k miles ago\n"
"motor mounts\n"
"tranny mounts\n"
"Diff and tranny fluids with royal purple synchromesh and mobil1 ~ 10k miles ago\n"
"Replaced all known hot spots for vacuum leaks\n"
"Clutch, flywheel, guibo, levers, RMS and all accessories ~ 10k miles ago\n"
"Driveshaft ~ less than 1k miles ago\n"
"Thrust arms ~ 3k miles ago\n"
"Tie rod ends ~ 3k miles ago\n"
"fuel pump ~ 20k miles ago\n"
"fuel filter x2 ~ most recently 5k miles ago\n"
"Fuel pump relay ~ 10k miles ago\n"
"air filters ~ 7k miles ago\n"
"oil filter housing rubber mounts ~ 10k miles ago\n"
"all 4 o2 sensors ~ 10k miles ago\n"
"Chain tensioner ~ 10k miles ago\n"
"Re conditioned Vanos solenoids (o-rings,gaskets, soldering etc) ~ 10k miles ago\n"
"Oil pan drain plug will NEVER EVER EVER EVER STRIP MUAHHAHA ~ 2k miles ago\n"
"All new power steering hoses ~ 10k miles ago\n"
"All pulleys and tensioners except for the power steering pump pulley ~ 10k miles ago\n"
"Serpentine Belt and accessory belt ~ 10k miles ago\n"
"I never had the SAP SES light but i had it deactivated with the tune\n"
"Added: Brand new rear tires and Brand new stoptech slotted/drilled rear rotors and pads\n"
"I know i'm missing other things. i've replaced a lot of misc stuff\n"
"I have receipts for almost everything i've just listed here.\n"
"I also have all files and videos of the dyno in regards to my custom tune.\n"
"Pictures:\n"
"Here's a video of one of my pre-tune dyno pulls:\n\n"
"The car has been garaged its whole life. I've spent thousands of dollars on maintenance because I sincerely thought this day would never come. No expenses were spared on the car. I love the damn thing <3\n"
"Im asking $15,500 OBO\n"
"Im asking 15,400$\n"
"Im asking 15400$\n"
"Im asking $15400\n"
"Im asking 15 400$\n"
"Im asking $15 400\n"
"Im asking 15.400$\n"
"Im asking $15.400\n"
"Im asking $ 15,400\n"
"Im asking 15,400 $\n"
"Im asking 15.400 $\n"
"Im asking $ 15.400\n\n"
"I have the title in hand\n"
"You're welcome to come test drive it but only if you have cash in hand.\n"
"You won't be disappointed.\n"
"You can contact me by email: han.kim318 at gmail.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")