using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<link (?=[^>]*rel=\s*['""]stylesheet['""])(?![^>]*href=\s*['""]http)[^>]*>";
string input = @"<link rel=""stylesheet"" href=""http://blahblah"">
<link rel=""stylesheet"" href=""//"" >
<link rel='stylesheet' href='//' >
<link rel='stylesheet"" href='//' >";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}