use strict;
my $str = '0.0.0.0
1.0.0.0
1.0.0.1
01.0.0.1
1.00.0.1
1.0.00.1
1.0.0.01
1.0.0.254
1.0.0.255
10.0.0.1
11.0.0.1
11.20.0.1
11.99.0.1
11.100.0.1
172.15.255.254
172.16.0.1
172.19.254.254
172.31.255.254
172.32.0.1
192.168.0.1
192.169.0.1
223.0.0.1
223.255.255.254
223.255.255.255
224.0.0.1
255.0.0.0
255.0.0.1
255.255.0.1
';
my $regex = qr/^(?!(192\.168\.))^(?!(172\.(1[6-9]|2[0-9]|3[0-1])\.))^((([1-9]|1[1-9]|[2-9][0-9]|1[0-9]{2}|2[0-1][0-9]|22[0-3])\.)((0|1[0-9]{0,2}|[2-9][0-9]|2[0-4][0-9]|25[0-5])\.){2}(1[0-9]{0,2}|[2-9][0-9]|2[0-4][0-9]|25[0-4]))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}