using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[<>\&\~\|\@]";
string input = @"< > & ~ | or @
tes<t
this is magic
Testi|g
m@ster
&
Tese_ting
asdf.asdf
asdf..~.
asdf>?";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}