package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[(([^][]|\[([^][]|\[[^][]*\])*\])*)\]`)
var str = `[0,0,0,[12,2],0,0,[12,[1,2,3]],12,0,[12,2,[2]],12,0,12,0,0]`
var substitution = "{\1}"
fmt.Println(re.ReplaceAllString(str, substitution))
}