#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[(([^][]|\[([^][]|\[[^][]*\])*\])*)\]"
Local $sString = "{0,0,0,[12,2],0,0,[12,[1,2,3]],12,0,[12,2,[2]],12,0,12,0,0}"
Local $sSubst = "{\1}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)