use strict;
my $str = '{0,0,0,[12,2],0,0,[12,[1,2,3]],12,0,[12,2,[2]],12,0,12,0,0}';
my $regex = qr/\[(([^][]|\[([^][]|\[[^][]*\])*\])*)\]/p;
my $subst = '{\\1}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";