$re = '/\[\?q\](.*?)(?:\[\?p\]|<)/';
$str = '[?q]this is a test[?p]
[?q]this is a test<RANDOM_TAG>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);