const regex = /<div[^>]+id\s*=\s*['"]([^'"]+)['"][^>]*>/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div[^>]+id\\s*=\\s*[\'"]([^\'"]+)[\'"][^>]*>', 'gi')
const str = `<div id='right_arm'><img src='images/001.gif' /></div>
<div id='right_af_arm'><img src='images/002.gif' /></div>
<div id='fegh_header'><img src='images/003.gif' /></div>
<div id='left_paper'><img src='images/004.gif' /></div>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}