use strict;
my $str = '+70 888 777 1 1 3';
my $regex = qr/\D/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";