package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([-a-zA-Z0-9@:%._\+~#=]{2,256}\.[a-z]{2,6})\b([-a-zA-Z0-9@:%_\+.~#?&\/=]*)`)
var str = `what is <http://google.com>?
what is www.ibm.com?
are these the Droids.I.com?Lookingfor=Yes`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}