using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"foo(?:\sbar)?(?:\sbaz)?|bar(?:\sbaz)?|baz";
string input = @"foo bar baz
foo baz bar
baz bar foo
foo bar
foo baz
bar baz
foo
bar
baz";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}