$re = '/foo(?:\sbar)?(?:\sbaz)?|bar(?:\sbaz)?|baz/m';
$str = 'foo bar baz
foo baz bar
baz bar foo
foo bar
foo baz
bar baz
foo
bar
baz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);