using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https?:\/\/regex101\.com\/?(?:r\/(?P<link>(?:[a-zA-Z]{2}\d){2})(?:\/(?P<version>\d+)?)?)?$";
string input = @"http://regex101.com
http://regex101.com/
http://regex101.com/r
http://regex101.com/r/
http://regex101.com/r/FakeFakeFake
http://regex101.com/r/wY0rM7
http://regex101.com/r/wY0rM7/
http://regex101.com/r/wY0rM7/1
http://regex101.com/r/wY0rM7/11
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}