import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?:\\/\\/regex101\\.com\\/?(?:r\\/(?P<link>(?:[a-zA-Z]{2}\\d){2})(?:\\/(?P<version>\\d+)?)?)?$";
final String string = "http://regex101.com\n"
+ "http://regex101.com/\n"
+ "http://regex101.com/r\n"
+ "http://regex101.com/r/\n"
+ "http://regex101.com/r/FakeFakeFake\n"
+ "http://regex101.com/r/wY0rM7\n"
+ "http://regex101.com/r/wY0rM7/\n"
+ "http://regex101.com/r/wY0rM7/1\n"
+ "http://regex101.com/r/wY0rM7/11\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}