const regex = /^https?:\/\/regex101\.com\/?(?:r\/(?P<link>(?:[a-zA-Z]{2}\d){2})(?:\/(?P<version>\d+)?)?)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https?:\\\/\\\/regex101\\.com\\\/?(?:r\\\/(?P<link>(?:[a-zA-Z]{2}\\d){2})(?:\\\/(?P<version>\\d+)?)?)?$', 'gm')
const str = `http://regex101.com
http://regex101.com/
http://regex101.com/r
http://regex101.com/r/
http://regex101.com/r/FakeFakeFake
http://regex101.com/r/wY0rM7
http://regex101.com/r/wY0rM7/
http://regex101.com/r/wY0rM7/1
http://regex101.com/r/wY0rM7/11
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}