use strict;
my $str = 'http://regex101.com
http://regex101.com/
http://regex101.com/r
http://regex101.com/r/
http://regex101.com/r/FakeFakeFake
http://regex101.com/r/wY0rM7
http://regex101.com/r/wY0rM7/
http://regex101.com/r/wY0rM7/1
http://regex101.com/r/wY0rM7/11
';
my $regex = qr/^https?:\/\/regex101\.com\/?(?:r\/(?P<link>(?:[a-zA-Z]{2}\d){2})(?:\/(?P<version>\d+)?)?)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}