import Foundation
let pattern = #"^https?:\/\/regex101\.com\/?(?:r\/(?P<link>(?:[a-zA-Z]{2}\d){2})(?:\/(?P<version>\d+)?)?)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://regex101.com
http://regex101.com/
http://regex101.com/r
http://regex101.com/r/
http://regex101.com/r/FakeFakeFake
http://regex101.com/r/wY0rM7
http://regex101.com/r/wY0rM7/
http://regex101.com/r/wY0rM7/1
http://regex101.com/r/wY0rM7/11
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)