$re = '/^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[!@#$%^&*()\-_+=\/?.,>~\\\\|\[\];:"\'{}])(?=\S+$).{8,}$/m';
$str = 'aZ1!aZ1!"\'ss
at least 1 small letter
at least 1 upper case letter
minimum of 8 characters
at least 1 number
at least 1 special character';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);