Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(?:(?<LEADING_PUNCT>\+?[-. (]*)(?<COUNTRY_CODE>\d{1,3}))?(?<OPT_DELIM_1>[-. )(]*)(?<AREA_CODE>\d{1,3})?(?<OPT_DELIM_2>[-. )(]*)(?<PREFIX>\d{3})(?<OPT_DELIM_3>[-. )(]*)(?<SUFFIX>\d{4})$
/
gm
Input 1
1
New
555 1212 555-1212 555.1212 5551212 936 555 1212 936-555-1212 936.555.1212 (936) 555-1212 9365551212 1 936 555 1212 1-936-555-1212 1.936.555.1212 1 (936) 555-1212 19365551212 +1 936 555 1212 +1-936-555-1212 +1.936.555.1212 +1 (936) 555 1212 +19365551212 23 4 555 1212 23-4-555-1212 23.4.555.1212 2345551212 +23 4 555 1212 +23-4-555-1212 +23.4.555.1212 +2345551212 +23 936 555 1212 +23-936-555-1212 +23.936.555.1212 +23 (936) 555 1212 +239365551212 +233 936 555 1212 +233-936-555-1212 +233.936.555.1212 +233 (936) 555 1212 +2339365551212