$re = '/^.*(?=(?:[^\sA-Z]*[A-Z]){2})/';
$str = 'Unseen ServanTThis creature can be summoned with the spell Unseen Servant.Unseen ServantCreature -1No AlignmentMediumMindlessSource Core Rulebook pg. 380Perception +0; darkvisionLanguages - (understands its creator)Skills Stealth +8Str -4, Dex +2, Con +0, Int -5, Wis +0, Cha +0Invisible An unseen servant is invisible, though it normally doesn’t Sneak, so it is usually only hidden.AC 13, Fort +0, Ref +4, Will +0HP 4; Immunities disease, mental, non-magical attacks, paralysis, poison, precision, unconscious
; Resistances all damage 5 (except force or ghost touch)Speed fly 30 feetForce Body An unseen servant’s physical body is made of force. It can’t use attack actions. It can move and use Interact actions to do things such as fetch objects, open unstuck or unlocked doors, hold chairs, and clean. It can’t pass through solid objects.
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);