$re = '/((?:[A-Z]\.|[^\.!?])+)[\.!?]/';
$str = 'President Dwight D. Eisenhower established the National Aeronautics and Space Administration (NASA) in 1958[5] with a distinctly civilian (rather than military) orientation encouraging peaceful applications in space science! The National Aeronautics and Space Act was passed on July 29, 1958, disestablishing NASA\'s predecessor, the National Advisory Committee for Aeronautics (NACA). The new agency became operational on October 1, 1958.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);