using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[[:ascii:]]*[@][A-z0-9_.-]*";
string input = @"ale.vegas@ahoo.co.uk
ale.vegas@yahoo.co.uk";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}