re = /[[:ascii:]]*[@][A-z0-9_.-]*/
str = 'ale.vegas@ahoo.co.uk
ale.vegas@yahoo.co.uk'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end