$re = '/(?=(?!-)\d{4})\b\d{4,}\b/';
$str = '2014
1106 **2014** **9899**
**11500**
234-233-2014
234-234-1100
-1100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);