re = /<\/body>(?![\s\S]*<\/body>[\s\S]*$)/i
str = '<html>
<body>
</body>
</html>
<html>
<body>
</body>
</html>'
subst = '<tag/>'
result = str.sub(re, subst)
# Print the result of the substitution
puts result