const regex = /(^|\|)(?!NULL(?:$|\|))([^|]*)(?=$|\|)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\|)(?!NULL(?:$|\\|))([^|]*)(?=$|\\|)', 'g')
const str = `TEST|123NjyfjUghfLL|NULL|NULL DATA|TEST NULL|TEST|NULL`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);