use strict;
my $str = 'TEST|123NjyfjUghfLL|NULL|999|NULL DATA|TEST NULL|TEST|NULL';
my $regex = qr/(^|\|)(?!(?:NULL|[0-9]+)(?:$|\|))([^|]*)(?=$|\|)/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";