re = /^builds\/job\/(?P<job_name>(larch|thunder))\/start\/(?P<start_date>[0-9]+)\/end\/(?P<end_date>[0-9]+)\/$/
str = 'builds/job/larch/start/123/end/123/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end