#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)^(?P<machinenr>[^\|]*?)\|" & @CRLF & _
"(?P<controldone>[^\|]*?)\|" & @CRLF & _
"(?P<nrofitems>[^\|]*?)\|" & @CRLF & _
"(?P<items>[^\|]*?)\|$"
Local $sString = "446408|0|1|111|446408|0|3|99884|111|73732|446408|0|0||"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")