package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?P<machinenr>[^\|]*?)\|
(?P<controldone>[^\|]*?)\|
(?P<nrofitems>[^\|]*?)\|
(?P<items>[^\|]*?)\|$`)
var str = `446408|0|1|111|446408|0|3|99884|111|73732|446408|0|0||`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}